to ragnar, but also anyone interested in Gimp-win

Community Forums/Developer Stations/to ragnar, but also anyone interested in Gimp-win

Bob3d(Posted 2005) [#1]
LOL!

It's been me [Joe2000] to discover why wacom tablets didnt work with 2.23 Gimp for Windows, and several other previous...

I googled a lot and did seem loads of people were suffering it, and was related to a bug in GTK more than in GIMP...was howthat handled the tablet...

I tried lots of things. as I had done before with previous versions with no luck....

Here's the trick, ragnar(and anyone interested) :

- This works with 4.78-6 driver(intuos and graphire 1 and 2, it seems), have not tested with flamant new one only for intuos 3, as I have an intuos1, beware that, may 3 version has no support, but try to guess (here in this intuos 1 9x12, but looks other guy [which was quite sad, but didnt gave me the thanks or antything,lol) made this work also for his intuos 2, doing what i mention] .Launch gimp from a bat in the gimp folder (right click on gimp desktop icon, properties, target folder) so that u write the name of gimp exe, and as command switch just --use-wintab (yup, during years, --ignore-wintab served to use wacom with no presure, just as core pointer, as wacom support made jerking when accessing toolbar.No happen ANYMORE. This works perfect also, can acces all with pen). the default in gtk i think is ignoring it, so u need the command, andfrom a bat file... just after a windows restar with all installed, it will work.

-the key thing: dont do a custom aplication in wacom panel for it. that is: dont "add" "gimp application"...for 9x12 pen...etc...just use the standard "all applications one", and tweak pressure and all values u wish in general "all applicatioms"...as u use a custom for each other app, u wont mind doing this...

- u dont need to toch a bit devices settings in gimp(who knows, it may wreck the trick if u do)

Every body inmediately adds custom support for the app, to set the custom keys , custom pressure...that's why all of us were having probs, and why with a pre 2.03 i had the "illussion" of it just working for some minutes...lol...just i add custom app in wacom control panel and it automatically lost pressure,,,this is activated or put off without restarting gimp.u can test it if ur curious.

Man, the ink tool with presure rocks totally...gimp for windows (it's said this 2.2.3 to be the more stabl till date) with pressure is another world... (and it has advanced stuff like full png transparency, and tga alpha channel support)
It's bellow Open Canvas in stroke, of course, but is cool to have some pressure support with a very complete general editing 2d tool, totally free!...yay

just wanted to share, specially ragnar, that like me showed interest by open canvas and gimp pressure in many times..

even was near to just put u a pm in bc(dunno how to do this here) but then i thought maybe there could be other person interested on the trick..

gimp 2.2.3 is "quite" advanced.Nothing beats the king -IMHO!- , Adobe ps, but hey, quite a power for free (like blender)


nadia(Posted 2005) [#2]
Thanx Bob3d for sharing this...
I've also tried using the gimp with my wacom tablet and had some problems even with the newest release of the gimp.
Using the --use-wintab commandline switch is enabled by default. But I still get strange behaviour: selection marquee doesn't show, when using the mouse, the cursor is offset quite a bit from the actual drawing point, tool selection hangs sometimes etc....

But when I use the --ignore-wintab switch ( which I learned from above message). Now everything works fine but of course I loose the pressure sensitivity which is a great pity because the pressure response is really great in the gimp :-(
Iíll check if there is a newer tablet driver available, that might sort it out.


Bob3d(Posted 2005) [#3]
look:

First check that you are using the very latest 2.2.3 Gimp for windows at http://gimp-win.sourceforge.net/stable.html

use the stable, not the old.

Of course, do uninstall previous gtk and gimp, or we'd be doing nothing...

then install exactly the gtk that you also must download from that stable htm...then install the gimp...u need to use the exact version, reason why they put them together for download both.

then, as I said, the trick is not using it in the desktop shortcut, but rightclick(well, only first time) on it, properties, find target, and so it opens the folder where the binary is. Create new text file in that folder, put there gimp-2.2.exe --use-wintab

Rename that *.txt to *.bat. Execute the bat any time you want to load Gimp.

the offset happens when in gimp, you have set at preferences, devices, extended input devices you have not set in all devices "screen", but window or something.Put them all to screen, click on save settings there in input devices, close, and exit. Start again also with the bat file. It should work now.

remember: this was already known by everybody...what I think I discovered (perhaps someone else already knew, but I spent hours in google and every forum) is that you must not "add" gimp in Wacom panel, in control panel of MS windows...Just use the "all applications" default setting.

And say here, if it didn't work.Give more data if possible..I'm also curious if someone still has problems in this scenario, with this gtk and gimp version, and the trick...Of course, as I know how frustrating is have a flamant new 2.2.3 gimp (and every previous version I checked) and have no pressure sensivity for the wacom...

What wacom is it? Intuos 1, 2, 3?...graphire?which?
Mine is a 9x12 intuos 1.


Bob3d(Posted 2005) [#4]
oh, forgot:

use pc478-6 driver...that is, the newest for wacom 1, 2, graphire...i think the intuos3 has a more recent one, and only tested this with that 478-6


Every bit here can be important, so try to do just these steps...later on you can go changing stuff one by one, to discover your problem, but is essential to have a way that works...