Lightmapping prob...

Community Forums/Developer Stations/Lightmapping prob...

ICECAP(Posted 2004) [#1]
I have made a village in 3ds max 6 and exported it fine to b3d format. Its all good as far as that goes.

I take it into Gile[s] and lightmap it, looks good in there.

Now i export from Gile[s] to b3d and load it into blitz and what do you know all my transparent pics dont show, they are just boxes, and all the transparent geometry turns to solid.

Here are some pics:

Before lightmapping:

After Lihgtmapping:

jhocking(Posted 2004) [#2]
Sounds like an issue with exporting from gile[s]. Maybe you just have to adjust some settings when you export?

ICECAP(Posted 2004) [#3]
I tried ticking and unticking every box there was to tick, and still i get the above picture.

I even tried exporting to x and the exact same thing happened.


Its incredibly frustrating.

MadJack(Posted 2004) [#4]

Nice to see a fellow NZ'er on the boards. Your virtual Maori village looks interesting - apart from games, that's another useful aspect of Blitz, being able to write walkthrough code for commercial projects.

Unfortunately, I don't have Giles so can't comment on your problem - obviously the Giles forum will probably be your best bet - I understand the support's pretty good. If that fails you may need to write some code (in Blitz) to go through a model's surfaces and adjust surfaces as required.

Another option is Michael Reitzenstien's useful B3d Tweak utility, which enables you to alter brushes contained in a B3d file.

Hope some of this helps.

ICECAP(Posted 2004) [#5]
Well i was hoping to find a free or no $$$ way of fixing the problem :P, considering i paid NZ$100+ just for Gile[s] i feel a bit ripped off. I have not been able to get anything working right in it. Mabe its just me.

Cheers for your help tho.

MadJack(Posted 2004) [#6]
Have you posted this issue in the Giles forum?

ICECAP(Posted 2004) [#7]
Yeah, i am waiting for them to get back to me.

I just thought that mabe someone has had this problem before.

ICECAP(Posted 2004) [#8]
I just bought that tweak util, and i load my village into it and it screwed my geometry up something shocking!
Well i guess it wasnt that much to buy.

Any other suggestions?

ICECAP(Posted 2004) [#9]

After furiously bashing my head aginst the desk a little bit of code caught my eye:

HWMultiTex False

I took that out and no more blank pictures. However...
I am now getting flashing lightmaps.
Hmmmm is there no end to my problems...

Again if anyone has found a way of fixing lightmaps so that they dont pop in and out when your moving around, let me know.

In the mean time i am going to continue bashing my head aginst the desk and see if i can catch any other odd pieces of code that shouldnt be there.

ICECAP(Posted 2004) [#10]
Ahhhh... finally a solution.

I have changed (in Gile[s]) the lightmapping type from Modulate 2x to Multiply, and it works perrrrrrfectly.

Thanks for all your help.


Dreamora(Posted 2004) [#11]
Sounds like you have a "crappy" graphicscard ...

Physt(Posted 2004) [#12]
Can you post a pic of the wonderful results?

ICECAP(Posted 2004) [#13]
Ummmmm I have an FX2700SE with 256mb of ddr, so I dont think its crap at all, my drivers are a bit screwy tho. That might be the prob.

Here we are:

Turned out rather nicely i thought.

Thanks for all your help.

wizzlefish(Posted 2004) [#14]
is that a concentration camp scene?

ICECAP(Posted 2004) [#15]
Haha, no its not.
Its a pre european maori village (original people of New Zealand)

Its purely educational.

wizzlefish(Posted 2004) [#16]
Looks good.