Gile[s] screws geometry...

Community Forums/Developer Stations/Gile[s] screws geometry...

ICECAP(Posted 2004) [#1]
I have just created a small village in 3ds max and exported it using the b3d exporter. When i import it into Gile[s] to do the lightmapping, it screwes around with my objects and puts some (not all) at funny angles.

Is this a bug? Or is there a work around.

Also i try and adjust them back to the correct angles that they were previously at and the objects jump around like crazy. I alter the Yaw of an object and it starts putting random numbers in the Pitch or Roll boxes.

Anyone else found this?

Mustang(Posted 2004) [#2]
Post this here:

ICECAP(Posted 2004) [#3]

Psionic(Posted 2004) [#4]
Do some of the objects share the same name? make sure all objects have an individual name, I seem to remember having a similar problem a while ago ;-)

ICECAP(Posted 2004) [#5]
The same name?? Like in 3DS or something?

I will look into that... does it matter if they are called "Fence1" "Fence2" etc... ???

Big&(Posted 2004) [#6]
Have you reset the X-Form and collapsed the stack before exporting?

Difference(Posted 2004) [#7]
I have the same problem with Ultimate Unwrap. Blitz imports the models fine, but UU displaces parts of the mesh. All parts have reset X-Form and are collapsed.

MAX - > B3D done via B3D Pipeline.

With MAX > UU all is fine.

IPete2(Posted 2004) [#8]

I have reported this to Fredbourg many months ago, and I think it was supposed to be at least partially fixed...

The good news is that if you select you objects individually, in an attempt to manually reset them, they should reset themselves to the correct orientation as they should be, er at least that's what happened when I recently tried to adjust them manually. Don't actually move them , just select them.

I hope this helps.


AdrianT(Posted 2004) [#9]
heh just incase people aren't doing it right. when I trained some new artists at a previous place of work, a lot of them didn't know how to colapse the stack properly.

The way many did it was when in the edit mesh modifier, right click on the selected object and choose colapse all in the right click menu.

the only way that was guaranteed to work was to go to the Utilities Tab in the control panel where reset-xform is, reset the X-form first and then go back and select the Collapse utility, by default <Mesh> is checked in the panel, change that so <modifier result> and then click <collapse selected> and you should have done it properly. (a

IPete2(Posted 2004) [#10]
Hey Evak,

Thanks for that tip, I'll try it out.


Difference(Posted 2004) [#11]
I just tried evaks tip. I still have displacement in UU but not in Blitz.

ICECAP(Posted 2004) [#12]
Yeah, they change to their original orentation when i select them and try to alter the rotation of them or position. Not when i just select them tho.

I went through my whole scene resetting all the objects and then i clicked the render button and they all went back to their incorrect positions. :S

I will try collapsing the village to one mesh. Do you have to do that though? I thought i read somewhere that Gile[s] is supposed to support seperate objects in one file?

Thanks for your help guys.

Big&(Posted 2004) [#13]
Have you tried exporting your mesh as an ASE?
(Just to see if its still messed up)

IPete2(Posted 2004) [#14]

Reset a couple and the save the giles scene off, then reload and check if it stayed the same.