gameSpace/trueSpace object name problem

Community Forums/Developer Stations/gameSpace/trueSpace object name problem

ryan scott(Posted 2004) [#1]
I just bought gameSpace, which for most intents and purposes is the same as truespace.

i tried Save Object for levels, objects, etc. Also tried saving entire scenes, but those don't save in b3d format.

The object or objects I save are named, according to the Object Info panel.

I even tried selecting all the objects in the level (well that's the only way to save separate objects together, in b3b format). I changed the name from 'selection' to 'root'.

I bring them into blitz, and I cannot read the EntityName, it's always blank.

I can't figure out what I'm doing wrong.


any clues?

Eric(Posted 2004) [#2]

Try using LoadAnimMesh...


EntityName$(GetChild('Your Object's Handle',1))

Even if you only have one object, Truespace makes that object a child of the scene.

It works, and use it all the time.


Oh yeah, You will have to parse the Text, because Truespace puts "Frame.." Before the Name, I don't know why or how to get rid of it, but you can do that in code.