Blitz3D + FastExtension

Blitz3D Forums/Blitz3D Userlibs/Blitz3D + FastExtension

RGR(Posted 2014) [#1]
Blitz3D + FastExtension Shadow DemoPrograms produce User lib not found at start of compiled exe

It works on a 32 Bit System when the demo programs get started from the IDE. But they do not run as compiled exes.
Compiled Exes work on 64 Bit Systems with Win 7 - not on Win 8.

32 Bit Computer: Every Shadow Example of Fast Extensions works when started from the IDE - but not when it is compiled and starting the exe.
I tried it on 3 32 Bit Systems (XP, Vista, Win 7)
The Exes stop after 1 second with a User lib not found Message

On 3 64 Bit Computers (Win 7, Win 8.1)
On Win 8.1 it stops with a Memory Access Violation Message
Only Win 7 64 Bit seems to be reliably working.

All Programs started from the same USB Stick. And complete Folder copied to the Desktop and started from there ...

It means that the old Blitz3D programs with FastExtension are running on some Computers and on many they do not.
Just to let you know and get response if others made the same or different experiences.

Rick Nasher(Posted 2014) [#2]
Can't confirm this.
I'm currently running on Win7 64bit and the exe's work fine here(at least: as long as you copy the *exact* folder structure for it to find the FastExt.dll and media).

I compiled the example "ShadowsMultiple_TrickForPlatformers.exe" on my Win7 64bit, put it on a USB stick and ran this on a system with Win7 32bit: all fine there too.

Have yet to try a Win8.1 system, but I believe for FastExt there is a compatibility problem with the latest Blitz3d update that fixes a Win8 slowdown issue or something. There is a fix for that too I believe:

RGR(Posted 2014) [#3]
You write *Can't confirm this* but have not understood what I wrote?

I wrote its ok on Windows 7 64 Bit Systems and actually you confirmed this!
But I also wrote about the problem that an exe when compiled on 32 Bit Systems does not run on a Win 7 32 bit system and not on Win 8 ... so what is it what you can't confirm? Have you tried that or not? Otherwise there's no need to confirm or not to confirm anything at all.

What you added is, that in your case (what I didn't try yet) the shadow examples in connection with fast extension compiled on a Win 7 64 Bit Computer were running errorfree on a 32 Bit Computer? That would be great.

If this is so, then to port the Blitz3D development system to the Win 7 64 Bit computer will solve the problem; compiling the programs there would make them work again on all Systems. But we have to test this first.
I will test that during the next days and hopefully find out that this works.

Win 8 .... There's a fix for that I believe
Dear Rick Nasher ... please don't get this wrong ... Computing has nothing to do with belief - you can believe in the church and at other places where facts are worth nothing ...
In Science, and Computer and Software is Science, we need facts or just don't talk about it; especially if we don't have them ready ...
We will have to find out. If an exe if compiled on a 64 Bit system runs without MAV on an 8.1 Computer then B3D+FastExtension is still usable - otherwise not. It does not help if it runs on some special machines but not on every where it should.

Rick Nasher(Posted 2014) [#4]
Hmm, sorry was kinda late. Not answering your question about Win8.1 X64 systems at all then..

I can't currently test this right now cause I'm not planning on installing 8.1 permanently on my system. Who in the industry does really, if given the choice.. well unless you have a touchscreen(I'll hold out for Win9 though ;-), but nevertheless: I understand a lot of potential customers don't really have a choice, hence the need to know if this works OK.

For now I can only test on Win8.1 32bit in a VMware environment which doesn't allow me to install the 8.1 64bit version as I can't enable Virtualization in BIOS for this aging HP. In Win8.1 32bit it also works fine as you already found out:

Pretty weird that you couldn't get it to run under Win8.1 X64. What on earth could prevent this?

- Did you try if the versions of Blitz3d/FastExtension make any difference?
Like for instance not the very latest Blitz3d 1.107/1.108 with the Win8 fix, but bog old Blitz3d 1.106 with FastExtention 1.17?

- Anybody else tried compiling and running a Blizt3d+fastext shadow example on Win8.1 X64?

Kryzon(Posted 2014) [#5]
See if this helps:

Rick Nasher(Posted 2014) [#6]
Already suggested that Kryzon, did you test that yourself?

Osoko(Posted 2014) [#7]
I've just made the upadte from Windows 8 to 8.1. ( 64 bit )

Everythings worked well on windowsw 8 with 1.106 blitz with fastlib and the winfix.dll from MixailV.

Now with 8.1 :

Problem 1 :

II've got a warning : entry point of procedure missing "httpPushClose" from system_32_\UrlMon.dll when i launch protean.

The same when i launch a compiled blitz program ! It is a warning and i can launch the apps

found maybe an issue here :

But don't want to try it as i need my programm to detect this and correct the problem. if i try the procedure it will maybe be OK for my computer but not for user of my soft under windows 8.1

i precise that i use 1.106 with fastlib and the winfix.dll from MixailV

ref :

Problem 2 :

If i compile from Protean in compatibity mode i've retrieve the good resolution using api_GetSystemMetrics(SM_CXSCREEN)

But if i ccompile and launch the exe, api_GetSystemMetrics(SM_CXSCREEN)response 1280 instead of 1920....

If i check the shotcurt and disable the scale option, i get the good value back.

Problem 3 :

Lost the touchscreen fast response using the command from User32.dll


Win8 use now a WM_POINTER : if someone has any indication to use it correctly with fast response. I prefer to desactivate gesture dectection for fast response that was the purpose of TWF_WANTPALM parameter and work's perfectly : Instant response to the touch.

Windows 8.1 : GRRRRRRRRRRRRRRRRRRRRRRR !!!!!!!!!!!

Rick Nasher(Posted 2014) [#8]
You probably tried already, but was wondering if happens also if you do it without Protean on the bog old standard IDE?

Osoko(Posted 2014) [#9]
In the blitz IDE i can compile without the warning : (entry point of procedure missing "httpPushClose" from system_32_\UrlMon.dll)

But if i produce the exe and run it, i get the warning back.

And api_GetSystemMetrics(SM_CXSCREEN) still response 1280 instead of 1920....

Osoko(Posted 2014) [#10]
Forget to mention that on the first start of my blitz apps, Windows 8.1 did install DirectPlay automaticaly.

Other bug in my system : font are looking blured i normal blitz IDE and in chrome for example. Start chrome in Windows 8 mode : get it in 1280 displaying as a part of the fullscreen !

@Rick Nasher : i ve got fastlib , what is this Blizt3d+fastext shadow example you show ? I didn't found it. but for example works perfectly. Can test it on 8.1 64bits

Rick Nasher(Posted 2014) [#11]
If the blurry fonts are appearing everywhere(not only in B3D) then miggt be a common Win8(.1) issue. There's is a fix for that, but will need to look it up(at work).

The screenshot is from:

If you like that one, you'll love the ProShadows_008(sdk) from:

*** WARNING: the website mentioned above has been reported to be unsafe! But: the code/effect is great, just don't click on pictures I guess and use a sandbox to extract and run the zip in. I didn't get problems from it, but been a while since I downloaded it and better to be safe than sorry.
Dunno how applicable it is in other environments(like free roaming) though, haven't delved into it(yet).

Osoko(Posted 2014) [#12]
Hi Rick ; demo works fine !

Found turn around for the problem 2 : not concerning windows 8 but rather the display option which in my case is set up for bigger font !

look at :


make a function for this :

with decls :

api_GetDeviceCaps% (hdc%, nIndex%) : "GetDeviceCaps" ; in "gdi32.dll"
api_GetDC% (hwnd%) : "GetDC" ; in "User32.dll"

When try it, i can't obtain the good result before the star of the apps. But after i write the DPI in a Ini file and display a message about this for the user to restart the apps. Then it will be ok.

For mention, google chrome failed to display correctly in full screen and display in 1280 instead of 1920.

Problem 1 : still here
Problem 3 : Still here and couple of hours looking for !

Guy Fawkes(Posted 2014) [#13]
Wait... HOW did you get your program to show up on google chrome? o.O

kiami(Posted 2014) [#14]
As Blitz3D is now free,

you may consider buying libraries for it.

Be careful, that you may buy a library without any upgrade support. If you don't care for support, then the pocket risk is upon you.

You may find helpful discussion about a particular library in Blitz forums.

RustyKristi(Posted 2014) [#15]
I'm also interested and currently using the trial version of this awesome library to test out some stuff. However, I sent an inquiry on the contact page of the site and still haven't got any answers from the author.

Too bad this also does not support the current version

Is this library still up and being updated?

Osoko(Posted 2014) [#16]
@Guy Fawkes : No, I mentioned chrome had trouble with DPI Scale, but no more since Windows 8.1 or chrome update. I didn't have my exe running under chrome.